[Pluto-help] configure PHP

Marco Cova giardini a libero.it
Sab 5 Maggio 2001 00:50:51 CEST


Paolo Alberti wrote:
> 
> Dopo aver installato MySQL e Apache
> (./configure --prefix=directory --enable-shared=max), ho provato ad
> installare PHP4 con il comando:
> #
> ./configure --with-apxs=apache_directory/bin/apxs --with-mysql=mysql_directo
> ry
> Ma alcune cose non vanno:
> 
> checking for working aclocal... missing
> checking for working autoconf... missing
> checking for working automake... missing
> checking for working autoheader... missing
> checking for working makeinfo... missing
> checking whether to enable maintainer-specific portions of Makefiles... no
> checking for bison... no
> checking for byacc... no
> configure: warning: You will need bison if you want to regenerate the PHP
> parsers.
> checking whether the C compiler (gcc) is a cross compiler... no
> checking for AIX... no
> checking for flex... no
> checking for lex... no
> ./configure: flex: command not found
> checking for flex... lex
> checking for yywrap in -ll... no
> checking lex output file root... ./configure: lex: command not found
> configure: error: cannot find output from lex; giving up
> 
> Ho riportato solo quel che non va.
> Mi manca qualcosa? Uso gli rpm? Se si, come disinstallo MySQL e  Apache che
> comunque vanno bene?
> Vi ringrazio e ciao a tutti.
> palbe a inwind.it
Noooo! Mai usare gli rpm per installare apache e php :-)
Direi che almeno almeno ti manca flex. Se poi vuoi installare anche
bison automake e autoconf, non farÓ male (ma non dovrebbe essere
necessario, credo). Li trovi da qualsiasi parte, per esempio qui:
fr2.rpmfind.net

Saluti,
Marco.




More information about the pluto-help mailing list