[PLUTO-help] qemu e make

mario rossi legazzelle2004 a yahoo.it
Gio 2 Mar 2006 16:16:29 CET


Ciao,

Ho problemi con l'installzione di qemu sul pc fisso.
Con il portatile non ho riscontrato nessun problema.
Scarico i 2 pacchetti qemu e kqemu, scompatto qemu e
ci infilo kqemu nella directory creata e scompatto
anch'essa.
./configure mi restituisce tutto regolare, comprese le
sdl e kqemu.
Non mi resta che digitare make (tutto rigorosamente da
utente).
make
for d in i386-user arm-user armeb-user sparc-user
ppc-user mips-user mipsel-user i386-softmmu
ppc-softmmu sparc-softmmu x86_64-softmmu mips-softmmu
arm-softmmu; do \
make -C $d all || exit 1 ; \
        done
make[1]: Entering directory
`/home/mario/qemu-0.8.0/i386-user'
make[1]: Nothing to be done for `all'.

Mi restituisce una decina di questi tentativi non
riusciti.
Ho pensato agli headers del kernel, ma credo sia tutto
ok:
mario a Desktop:/usr/src> ls
debug  linux  linux-2.6.11.4-20a 
linux-2.6.11.4-20a-obj  linux-obj  packages

Posto anche l'output di ./configure:
oloap a Desktop:~/qemu-0.8.0> ./configure
Install prefix    /usr/local
BIOS directory    /usr/local/share/qemu
binary directory  /usr/local/bin
Manual directory  /usr/local/share/man
ELF interp prefix /usr/gnemul/qemu-%M
Source path       /home/mario
/qemu-0.8.0
C compiler        gcc
Host C compiler   gcc
make              make
host CPU          i386
host big endian   no
target list       i386-user arm-user armeb-user
sparc-user ppc-user mips-user mipsel-user i386-softmmu
ppc-softmmu sparc-softmmu x86_64-softmmu mips-softmmu
arm-softmmu
gprof enabled     no
static build      no
SDL support       yes
SDL static link   no
mingw32 support   no
Adlib support     no
CoreAudio support no
ALSA support      no
DSound support    no
FMOD support      no
kqemu support     yes

KQEMU Linux module configuration:
kernel sources   
/lib/modules/2.6.11.4-20a-default/build
kbuild type       2.6

e anche /lib/modules:

mario a Desktop:/lib/modules> ls
2.6.11.4-20a-default    2.6.11.4-21.9-default     
scripts
2.6.11.4-21.10-default  2.6.11.4-override-default
2.6.11.4-21.7-default   precompiled

Credo che ci siano delle incongruenze. Posso azzardare
dei pensieri, ma non vorrei dire boiate e sopratutto
fare passi falsi nelle modifiche.

Spero di aver dato piu' dati possibili per risolvere
la cosa e mi scuso se il post  un po' lunghetto.
Grazie a tutti per gli eventuali aiuti.
Ciao 
Mario


La matematica? una mia opinione.
Mario


		
___________________________________ 
Yahoo! Messenger with Voice: chiama da PC a telefono a tariffe esclusive 
http://it.messenger.yahoo.com



More information about the pluto-help mailing list