[PLUTO-tech] vnc al boot

gigi-eliotisc eliotec a tiscalinet.it
Mer 22 Ott 2003 19:18:39 CEST


allego soluzione by Cri
ciao
gigi


-----------------------------------------------------------------
 From:   _Cri_ <bxxxxx a libero.it>
  To:     eliotec a tiscalinet.it
  Subject:Riusciti!!!

  Poi siamo riusciti a far avviare vnc al boot!

  Abbiamo scoperto che settare suid lo script non ha effetti
  (me lo avvia sempre come root); il trucco (grazie a Albx) e' avviare con
  "su" il server!  In sostanza:

  - in /etc/init.d/ aggiungi lo script vnc (chmod 755)

  - in /etc/init.d/rc.5/ fai un symlink allo script
    ('ln -s /etc/init.d/vnc S20vnc)

    Forse questo passo puo' essere saltato e fatto con Yast -> Sistema
    ->Editor dei runlevel, ma non ho provato...

  - lo script vnc dev'essere cosi':

    #!/bin/bash
    case "$1" in
      start)
      su iltuoutente -c "/path/del/vncsever -geometry 800x600 -depth 8"
      ;;
      stop)
      il comando per uccidere il server
      ;;
    esac

  - Poi va perfezionato con altri case (restart, stop, ecc) cmq l'avvio
    funziona!
  A giovedi'

-------------------------------------------------------------------------------------------





Il 22/10/2003 17.36.07, "Salvatore Basso" <sasab a pixteam.com> ha scritto:

>Ciao, infatti Ŕ come tu dici .. per lanciarlo basta eseguire vncserver e il
>suo funzionamento mi Ŕ abbastanza chiaro, solo che ho il problema di farlo
>partire in automatico all'avvio della macchina ! cercher˛ di adattare
>qualche script giÓ presente, qualora tu avessi qualche novitÓ fammi sapere !
>:-)
>grazie.
>
>                 - Salvatore
>
>
>---
>[This E-mail scanned for viruses by Declude Virus]
>
>_______________________________________________
>pluto-tech mailing list
>pluto-tech a lists.pluto.linux.it
>http://lists.pluto.linux.it/mailman/listinfo/pluto-tech
>
gigi vigano'
http://spazioinwind.libero.it/gili/gi/gi.htm 
http://www.lecco.linux.it
GPG/PGP encryption Key-Id:0xED8A84C8 





Maggiori informazioni sulla lista pluto-tech