[Pluto-help] configurazione scheda audio

ecobel a tin.it ecobel a tin.it
Dom 11 Mar 2001 17:59:08 CET


Premessa: non sar (per forza di cose) breve!
Nel mese di settembre 2000 ho acquistato la distribuzione linux 6.4 di
SuSe, e non sono riuscito a configurare la sound card quantunque la
stesso
fosse rilevata (comando lspci). Si tratta di una Creative Soundblaster
PCI 128 con chipset Ensoniq 1371.
L'assistenza della SuSE Italia non  riuscita ad aiutarmi e dopo diverse
manovre tese alla configurazione (da settembre 2000 a gennaio 2001)
decideva
di regalarmi la versione 7.0 appena uscita. Ma anche con questa non c'
stato niente da fare: la scheda non ne vuol sapere (faccio notare che
non
si tratta di un clone). Ho cercato, allora, di procurarmi tutte le
informazioni possibili al riguardo e ho incominciato a procedere per
tentativi con l'utilizzo
del comando modprobe.
Precisamente: modprobe snd-card-ens1371 , ma la risposta era sempre la
stessa: il modulo non c'! Ho cercato allora tale
modulo in /lib/modules/2.2.*/...   trovandolo!!! Panico. . . perch se
c' non lo carica? Nello scorrere la directory /lib mi accorgevo che era
presente
anche il modulo snd-ens1371. Ho provato con quello e ... con, credetemi,
enorme sorpresa ha funzionato. Ho, quindi, lanciato il comando lsmod
con il seguente risultato:
Module                            Size            Used by
snd-.ens1371                   9404               0   (unused)
snd-pcm                        28504               0   [snd-ens1371]
snd-timer                        8032                0  [snd-pcm]
snd-rawmidi                    9432               0  [snd-ens1371]
snd-seq-device                3360               0  [snd-rawmidi]
snd-ac97-codec             23904               0  [snd-ens1371]
snd-mixer                     22576                0  [snd-ens1371
snd-ac97-codec]
snd                               31852               0  [snd-ens1371
snd-pcm snd-timer snd-rawmidi snd-seq-devices

snd-ac97-codec snd-mixer]
soundcore                       2564               0  [snd]
usb-uhci                        17000               0  (unused)
serial                             42612              0  (autoclean)
memstat                          1476              0  (unused)
usbcore                         42344              1  [usb-uhci]
Sembrandomi che fosse andato tutto bene ho aggiunto nella parte finale
del file /etc/modules.conf le seguenti
righe di istruzioni:
alias char-major-116 snd
alias snd-card-0 snd-ens1371
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
A questo punto ho eseguito un re-boot facendo attenzione ai messaggi
visualizzati.
Con grande piacere  comparso:
Starting sound driver: snd-ens1371                done
No mixer config in /etc/asound.conf, you have to unmute your card!

Manuali alla mano cercavo di dare il volume al mixer con il comando
amixer col risultato:
Alsactl: no souncards found.
Editavo il contenuto del file /proc/asound/cards: stessa risposta No
souncards.
Il contenuto del del file /proc/asound/sndstat da il seguente risultato:

Card config:
--- no soundcards ---
Audio devices:  NOT ENABLED IN CONFIG
Synth devices:  NOT ENABLED IN CONFIG
Midi devices:    NOT ENABLED IN CONFIG
Timers:
7: system timer

Ma non  finita. Facendo lo shutdown a un certo punto compare:
Shuttingdown sound drivers: Alsactl: no soundcards found.

Prima domanda: perch quando il sistema viene inizializzato il driver
viene caricato mentre quanto si chiude
la scheda  scomparsa?
Ho fatto le seguenti prove:

modprobe -c:
tra gli altri compaiono i seguenti files:
/lib/modules/2.2.x/misc
/lib/modules/2.2.x/sound

modprobe -l:
compaiono tutti i file di prima tranne uno: /lib/modules/2.2.x/sound

Ho lanciato anche il comando lspci -vv e nella sezione riguardante la
scheda audio vi era la seguente riga:

pin A routed to IRQ 0

Qualcuno  in grado di spiegarmi tutto ci prima che mi spari un colpo?
Ringrazio anticipatamente.

emilio
-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: <http://lists.pluto.it/pipermail/pluto-help/attachments/20010311/24fed2ff/attachment.html>


More information about the pluto-help mailing list