[Pluto-help] httpd

Beppe beppebz a tin.it
Dom 29 Dic 2002 13:33:59 CET


La sinstassi corretta dovrebbe essere:

LoadModule config_log_module     modules/mod_log_config.so
# non il PATH assoluto, anche se non credo debba dare particolari problemi.
AddModule mod_log_config.c

Per quanto riguarda le righe che hai segnalato invece dovresti avere:

<IfModule mod_log_config.c>
# qui ci metti le opzioni che ti interessano
</IfModule>

Beppe

Alle 12:20, domenica 29 dicembre 2002, Giancarlo ha scritto:
> > mi pare di aver capito che  un'errore che riguarda un modulo,
> >dichiarato nel file di configurazione ma non presente nella dir. dove
> >realmente dovrebbe essere [scusa l'intreccio spero abbia capito cosa
>
> intendo]
>
> >controlla anche questa cosa, perch  capitato anche a me.
>
> ho controllato in httpd/modules e ci sono tutti i moduli nominati in
> httpd.conf
>
> >... per controllare rapidamente la sintassi dell'httpd.conf puoi digitare
>
> da
> un terminale:
> apachectl configtest
> [root a localhost root]# apachectl configtest
> Syntax error on line 212 of /etc/httpd/conf/httpd.conf:
> Can't locate API module structure `config_log_module' in file
> /etc/httpd/modules/mod_log_config.so: /usr/lib/libapr.so.0: undefined
> symbol: config_log_module
> ciao Giancarlo
> Ciao
> Beppe
>
> Alle 10:45, sabato 28 dicembre 2002, Giancarlo ha scritto:
> > >   Ciao a tutti .
> > >   Non riesco pi ad avviare apache, che mi  da questo errore:
> > >
> > >    [root a localhost root]# /etc/init.d/httpd restart
> > >    Interruzione di httpd:                                     [FALLITO]
> > >    Avvio di httpd: Syntax error on line 212 of
> > > /etc/httpd/conf/httpd.conf: Can't locate API module structure
> > > `config_log_module' in file /etc/httpd/modules/mod_log_config.so:
> > > /usr/lib/libapr.so.0:
> > >    undefined symbol: config_log_module        [FALLITO
> >
> >  Visto che non c' un errore di sintassi (ho controllato), ho provato a
> >
> > > commentare la riga 212, e succede una strana cosa: ho un errore alla
> > > linea successiva , la 213. Commentando la 213 l'errore passa alla linea
> > > successiva.
> > > Io non ci capisco un tubo, e se qualcuno ha un'idea gliene sarei
> > > riconoscente
> > > ciao
> >
> > _______________________________________________
> > pluto-help mailing list
> > pluto-help a lists.pluto.linux.it
> > http://lists.pluto.linux.it/mailman/listinfo/pluto-help
>
> _______________________________________________
> pluto-help mailing list
> pluto-help a lists.pluto.linux.it
> http://lists.pluto.linux.it/mailman/listinfo/pluto-help
>
>
> _______________________________________________
> pluto-help mailing list
> pluto-help a lists.pluto.linux.it
> http://lists.pluto.linux.it/mailman/listinfo/pluto-help




More information about the pluto-help mailing list