[Pluto-help] port forwarding

f.riccardo frick a pluto.linux.it
Sab 20 Lug 2002 19:04:45 CEST


in data 20/7/2002, giuseppe sportelli ha scritto:

>Salve a tutti aiuto aiuto !

in velocita` per provare a circoscrivere l'incendio visto
che e` il w-e ;)

>Allora ho un server red hat 6.1 con
>tre schede rete
>sulla eth0 ho la lan 192.168.x.y ( circa 40 pc) (lan 1)
>sulla eth2 ho il router adsl con tre ip pubblici assegnati diciamo 1.2.3.4
>1.2.3.5 1.2.3.6 tramite alisa ip .
>sulla eth1 ho ip 10.0.x.y su un'altra lan privata (lan 2)
>su tale macchina come giÓ detto ho red hat 6.1 con kernel 2.2.12-10 che voplendo potrei anche aggiornare .
>Ora vorrei eseguire un port forwarding verso un server web windows 2000 ( Ŕ nella lan 1)con ip 192.168.x.y1.
>Il kernel ha giÓ i moduli ip_masq_portfw , ip_masq_autofw. e ip_masq_mfw.
>Ora ho scaricato e installato ipmasqadm .
>do i seguenti comandi
>ipchains -A input -i eth2 -p tcp -d 1.2.3.4 80 -j ACCEPT
>ipchains -A forward -i eth2 -j MASQ

aggiungere qui un "ipmasqadm portfw -f" e` una buona idea credo

>ipmasqadm portfw -a -P tcp -L 1.2.3.4 80 -R 192.168.x.y1 80
>Non ho nessun errore

hai provato ipmasqadm portfw -l per vedere che ti da?

> ma quando eseguo il browser

da dove? hai provato da un host esterno? se e` uno di quelli
192.168.x.y guarda che c'e` un famoso trick =)

> con indirizzo
>http://1.2.3.4 non mi funge niente !

per non pentirsi dopo: il 2000 esce di suo vero?

>Ora le regole che ho scritte sono state provate con (le chains vuote e politiche in ACCEPT).
>A questo punto mi sorgono varie domande dove sbaglio?

prova innanzitutto col browser da un host che non sia sulla subnet
del server


-- 
saluti
riccardo fabris





More information about the pluto-help mailing list