[Pluto-help] Aiuto per uno shell script

Beppe beppebz a tin.it
Dom 10 Nov 2002 14:25:12 CET


Ciao !

Scusate il ritardo nella risposta;
In effetti come dice dido nelle release precedenti il 2.4.18
[ la versione giusto non la ricordo ] c'era un baco nel modulo uhci, e a
dirla tutta
anche un problema nel del protocollo HDLC, che creava problemi
proprio quando a seguito di una disconnesione magari solamente per problemi
di linea cercavi di riconetterti; la connesione veniva chiusa ma
l'HDLC teneva occupato il modem;
la soluzione piu' veloce era un rapido reboot del sistema.
Il problema a quanto ne so io  stato risolto con il 2.4.18;
io ho lo speedtouch  sinceramente problemi non ne ho.

> Scusate, forse Beppe  pi indicato di me per rispondere (sta facendo un
> articolo proprio su questo, giusto?)..
> Ma da quanto so, c' un bug nel modulo usb-uhci, che pare sia stato
risolto
> dal kernel 2.4.18 in poi... Pu essere il vostro caso?
> Dido

<cut>
Per libero :

> Modem Speedtouch usb
> Per far funzionare la connessione ADSL devo per forza fare questi passi:
> 1. avviare windows , connettermi, riavviare il pc con Linux e a questo
> punto la connessione funziona
> 2. avviare il pc con il model scollegato lanciando Linux, collegare il
> modem su una porta usb diversa dall'ultima usata e allora funziona il
> tutto.

Ma perch tutta sta procedura? non mi sembra il caso di passare da Windows
per lanciare la connesione !
Prova lo script in fondo all'messaggio, salvalo e avvialo al boot della
macchina.

Per Lorenzo:

> Salute a tutti
> a me serve una mano da un'anima pia che sappia programmare in shell script
> Il mio problema  che devo creare uno script che faccia determinate
> operazioni.
> Ho uno script che mi avvia il mio modem usb per connettermi tramite adsl.
>  Lo script funziona ma solo al secondo tentativo e dopo aver scaricato il
>  modulo usb-uhci.

Ad essere sincero non ho capito che modem hai comunque
sei sicuro che il modulo e " uhci " ??? prova a controllare cos:
# cat /proc/pci

> 1) lanciare lo script startmodem ( localizzato in /usr/local/bin )
> 2) dopo 20 secondi circa killare il processo relativo (  necessario e non
>  c' altra strada...)
> 3) rimuovere il modulo usb-uhci
> 4) rilanciare startmodem
Script:
#!/bin/sh
/sbin/modprobe n_hdlc
/sbin/modprobe ppp_synctty
/usr/local/bin/il_tuo_eseguibile
/usr/sbin/pppd call adsl





More information about the pluto-help mailing list