R: [PLUTO-help] export DISPLAY non funziona

Gian Uberto Lauri GianUberto.Lauri a eng.it
Lun 20 Feb 2006 09:42:14 CET


>>>>> "MM" == Malaguti Michele <michele.malaguti a ducati.com> writes:

MM> Scusa una domand ma sulla macchina red hat hai dato il comando
MM> xhost + in modo da aprire l'ingresso di altri display?  Sper
MM> funzioni

MA CHE CONSIGLI DAI ????????????????????????????

Leggersi il manuale di xhost e non andare dietro come pecoroni a chi
dice di usare 'xhost +'.

Date xhost+  e mandate pure  a quel paese  il collegamento SSL  con la
banca, che la password ve la leggono direttamente dagli eventi di X!

Dimenticatevi che esiste "xhost +" !!!!

Non si  danno permessi del  genere, mai! Che  se ci si abitua  a darli
quando si  in lan isolata ti  capita il momento in cui lo dai con una
macchina connessa in rete.

Si  da'  solo  "xhost  hostname",  e  anche  quello    potenzialmente
pericoloso  se ci  sono pi  utenti e  non tutti  fidati  su hostname,
perch  ricordo che  con xhost  non si  permette solo  di  accedere al
server  X in  scrittura (visualizzazione)  ma anche  in  lettura degli
eventi.

La cosa pi sicura da fare :

   trasferire dalla macchina col serve X alla macchina remota il
   file .Xauthority con scp, cambiando il nome al file (i.e. xau)

   sulla macchina remota dare i comandi 

   	 xauth merge xau
	 export DISPLAY=macchina_remota:0

-- 
 /\            ___
/___/\__|_|\_|__|___Gian Uberto Lauri_____________________
  //--\ | | \|  |   Integralista GNUslamico  
\/		    e allevatore di bug da competizione



More information about the pluto-help mailing list