[Pluto-help] (TA) solito problema, ma situazione ancora peggiore

Leonardo Boselli leo a dicea.unifi.it
Dom 11 Nov 2001 14:08:11 CET


Avevo problemi a collegarmi via ISDN in dialin ...
ossiva mi collegavo (su un TA esterno collegato a ttyS1 ) se 
entravo come terminale, mi chiedeva login e password, ma non mi 
funzionava il ppp , mentre su ttyS2 c'e`un modem analogico e li 
funziona tutto
poi ....
ho modificato il file inittab e ora e`semplicemente:
T2:23:respawn:/sbin/mgetty -x3 -s 57600 ttyS2
T1:2345:respawn:/sbin/mgetty -x9 -s 115200 ttyS1

ora su ttyS2 c'e`un modem anologico, mentre su ttyS1 c'e`un TA 
ISDN esterno.
Se mi collego sulla porta analogica tutto bene, entro in ppp ...
Se mi collego su quella ISDN mi viene fuori :
----------------------------------------
~
Debian GNU/Linux ttyS1 115200 (64000/HDLC)
**EMSI_REQA77E
}1              

dipolo!login: ~
-----------------------------------------
mentre sul log:
11/10 12:06:11 yS1  wfr: waiting for ``RING''
11/10 12:06:11 yS1   got: [0a][0d][0a]RING[0d]
11/10 12:06:11 yS1    CND: RING
11/10 12:06:11 yS1   wfr: rc=0, drn=0
11/10 12:06:11 yS1    CND: check no: 'none'
11/10 12:06:11 yS1  send: ATA[0d]
11/10 12:06:11 yS1  waiting for ``CONNECT''
11/10 12:06:11 yS1   got: ATA[0d]
11/10 12:06:11 yS1    CND: OKATA[0d][0a]CONNECT ** found **
11/10 12:06:11 yS1  send:
11/10 12:06:11 yS1  waiting for ``_''
11/10 12:06:11 yS1   got:  64000/HDLC[0d]
11/10 12:06:11 yS1    CND: CONNECT 64000/HDLC
11/10 12:06:11 yS1    CND: found: 64000/HDLC[0a] ** found **
11/10 12:06:11 yS1   waiting for line to clear (VTIME), read:
11/10 12:06:12 yS1    looking for utmp entry... (my PID: 17155)
11/10 12:06:12 yS1   utmp + wtmp entry made
11/10 12:06:12 yS1   tio_set_flow_control( HARD )
11/10 12:06:12 yS1   print welcome banner (/etc/issue.mgetty)
11/10 12:06:12 yS1   getlogname (FIDO AUTO_PPP), read:[ff][03]
11/10 12:06:12 yS1   getlogname (FIDO AUTO_PPP),
read:[c0]![01][02][00][0d] 11/10 12:06:12 yS1   input finished with
'\r', setting ICRNL ONLCR 11/10 12:06:12 yS1   
tio_get_rs232_lines:
status: RTS CTS DSR DTR DCD 11/10 12:06:12 yS1    login: use 
login
config file /etc/mgetty/login.config 11/10 12:06:12 yS1   match:
user='@!_', key='' 11/10 12:06:12 yS1   match: user='@!_', key=''
11/10 12:06:12 yS1   match: user='@!_', key='/AutoPPP/' 11/10 
12:06:12
yS1   match: user='@!_', key='' 11/10 12:06:12 yS1   match:
user='@!_', key='*'*** hit! 11/10 12:06:12 yS1   calling login:
cmd='/bin/login', argv[]='login @!^B' 11/10 12:06:12 ##### data
dev=ttyS1, pid=17155, caller='none', conn='64000/HDLC', name='',
cmd='/bin/login', user='@!^B'

11/10 12:06:12 yS1   setenv: 'CALLER_ID=none'
11/10 12:06:12 yS1   setenv: 'CALLED_ID='
11/10 12:06:12 yS1   setenv: 'CONNECT=64000/HDLC'
--

il log della porta anlogica mi dice:
--
11/10 12:03:39 ##### data dev=ttyS2, pid=335, caller='none', 
conn='57600', name='', cmd='/usr/sbin/pppd', user='/AutoPPP/'
--

e tutto funziona ...
se qualcuno vuole provare gli posso fare avere un account di prova.

Leonardo Boselli
nucleo informatico e telematico
Dipartimento Ingegneria Civile
Universita` di Firenze
V. S. Marta 3 - I-50139 Firenze
tel +39()0554796431 fax +39()055495333
http://www.dicea.unifi.it/~leo




More information about the pluto-help mailing list